09.01.118557
Matrox-Grafikkarte
Home Impressum Tipps auf wlsoft.de www.wlsoft.de
Programmieren weil es Spaß macht.
Hardware
Matrox-Grafikkarte
Nvidia-Grafikkarte
DVD-RAM
Scanner UMAX Astra 1220U
Externe Festplatte 500GB

Offene Fragen
VAIO VGN-CR11Z
Chemnitzer Linuxtage 2008

Tipps
Kernel-Update
Samba Installation
Samba Tipps
W2K und Linux
Vista und Linux
Port 113
Grub
fstab
VMware
Thunderbird
CapiSuite
VNC-Server
Bluetooth
Softmaker
Kopierer
Fotos
Soundprobleme
Antivirus-ClamAV
KDE Tipps
apt-get
Superkaramba
Firefox
Lazarus
Backup
Recoll
gpg
hibiscus
cups
Netzwerk
Rechteverwaltung
Dienste (daemons)
Firefox und Akregator
apt-proxy

Dateisysteme

Shell-Befehle
Fehlersuche
Fehlersuche fsck
Screenshots erstellen

meine Programme
wnfDesktopkalender
meine Scripte

EEE-PC
Tipps zum EEE-PC

NetBeans
Installation
HelloWorld
HelloWorld-2
Wichtige Dateien
Tipps
Jaybird

CrossKylix
Tipps

Drupal
Tipps

Python
Python & Qt-Designer 3
Python & Qt-Designer 4
Python & KDevelop
Python & Apache
Tipps
CherryPy

Matrox-Parhelia-Grafikkarten Treiber installieren

  • build-essential installieren
  • linux-headers-386 installieren (Version 2.6.15.24)
  • gcc 3.4 installieren
  • Herunterladen des Treibers von www.tuxx-home.at
$ export CXX=gcc-3.4
$ sudo sh matroxdriver-x86_32-1.4.4.2-installer.run
Section "Device"
Identifier "Standardgrafikkarte"
Driver "mtx"
BusID "PCI:1:0:0"
EndSection

Ich hatte genau das gleiche Problem unter Ubuntu 6.10 wie hier beschrieben:
  • Beim Starten der Ubuntu-Live-DVD bleibt nach der Anzeige von grub der Bildschirm schwarz (dort wird normalerweise das Hochfahren des Ubuntu-Systems angezeigt.)
  • Der X-Server startet mit einem zerstörten/zerstückelten Grafikbildschirm
Meine Vermutung ist, dass der Ubuntu 6.10 vesa-Grafiktreiber nicht mit der Matrox Parhelia läuft. Deshalb ist der Splash-Modus des Linux-Loaders nicht zu sehen und der X-Server läuft nicht ordnungsgemäß, da beide standardmäßig den vesa-Treiber nutzen.

Deshalb musste ich Ubuntu 6.10 folgendermaßen installieren:
  • Von der DVD im Text-Modus starten
  • Dann nach der Anleitung den Matrox-Treiber installieren
  • Dann startx und der X-Server läuft wieder
  • Sollte das Bild (z.B. der Cursor) zerstört/zerstückelt aussehen, dann liegt das daran dass vorher schon einmal der vesa-Treiber geladen war deshalb den X-Server noch einmal starten.
  • Dann in der Datei /boot/grub/menu.list in der Zeile kernel das splash entfernen, damit beim nächsten hochfahren des Rechners nicht wieder der vesa-Treiber geladen wird.

gunther logo  Letzte Änderung: 09.01.118557 - 00:00:00